Fail installing collected packages: spacy

I’m trying to use a different deeppavlov model with docker now.
Ontonotes seems to work as shown in the example on your website:

However when trying to install one of the other configs like so:
“docker run -e CONFIG=odqa/en_odqa_infer_wiki -p 5000:5000
-v /Users/user/Desktop/docker_dp_components_volume/:/root/.deeppavlov
-v /Users/user/Desktop/docker_host_venv_dir/:/venv

It all works fine until it gets to:
“Installing collected packages: blis, jsonschema, cymem, preshed, plac, wasabi, srsly, murmurhash, thinc, spacy”

And specifically the last one:
“subprocess.CalledProcessError: Command ‘[’/base/venv/bin/python’, ‘-m’, ‘pip’, ‘install’, ‘spacy==2.1.3’]’ died with <Signals.SIGKILL: 9>.”

Same happens for another config like: “doc_retrieval/en_ranker_tfidf_wiki”
With ner ontonotes_bert I’m getting:
“cannot create directory ‘/venv/ner/ner_ontonotes_bert’: No such file or directory”

Can anyone tell me what do I have to do to fix this?

Hi, @kostis95

Please, try to run your commands while specifying CONFIG values without / (CONFIG=en_odqa_infer_wiki, for example).

No that doesn’t work, it returns exactly the same message…
Maybe something else?


cannot create directory ‘/venv/ner/ner_ontonotes_bert’: No such file or directory error could be solved setting CONFIG=en_ranker_tfidf_wiki (it shouldn’t be / in CONFIG).
subprocess.CalledProcessError: Command ‘[’/base/venv/bin/python’, ‘-m’, ‘pip’, ‘install’, ‘spacy==2.1.3’]’ died with <Signals.SIGKILL: 9>. error isn’t occur when starting the DeepPavlov container on Linux. We will try to find a solution to the problem on Windows soon.

It doesn’t work when removing the “/” character.
CONFIG=en_odqa_infer_wiki returns the Same Error.
I’m also working on mac not on windows…