ASR and TTS Download

I’m following the ASR and TTS instructions. I ran python -m deeppavlov download asr_tts but it is failing to establish a connection. Is anyone else having this issue? I also tried doing model = build_model(configs.nemo.asr ,download=True) but it is giving me the same error. Is there an issue with the server or am I doing something wrong?

Hi, @seanle24245

Could you please send the error text and DeepPavlov version?

How do I check the version? I just did today python -m deeppavlov install asr_tts so I assume the latest?

This is the error message:
requests.exceptions.ConnectionError: HTTPConnectionPool(host=‘’, port=80): Max retries exceeded with url: /deeppavlov_data/nemo/quartznet15x5.tar.gz.md5 (Caused by NewConnectionError(’<urllib3.connection.HTTPConnection object at 0x7f3aefc210f0>: Failed to establish a new connection: [Errno 110] Connection timed out’,))

You could check DeepPavlov version with pip show deeppavlov.

I checked the availability of files, everything is OK. You should check your network policy.
Also you could try to download files manually: and and unpack files contents to directories with same names as archives in <your_home>/.deeppavlov/models/nemo directory. Then you could skip command python -m deeppavlov download asr_tts and remove download=True argument.

So I ran pip install deeppavlov inside of a virtual environment. Should the model files be downloaded into venv/lib/python3.6/site-packages/deeppavlov/models/nemo? I don’t have a .deeppavlov directory. Am I supposed to have one, or should I change the path for the model to inside of my virtual environment folder?