Fitting of loaded model can not be continued

Hi

I have tried to train DeepPavlov with my own FAQ, but it does not work somehow, whereas I have changed the configuration:

/usr/local/lib/python3.7/site-packages/deeppavlov/configs/faq/tfidf_logreg_en_faq.json

“data_path”: “/Users/michaelwechner/deeppavlov/faq_school_en.csv”

and was executing

python3 -m deeppavlov train tfidf_logreg_en_faq

But then I receive the following warning:

2019-12-26 13:10:54.137 INFO in ‘deeppavlov.core.data.simple_vocab’[‘simple_vocab’] at line 115: [loading vocabulary from /Users/michaelwechner/.deeppavlov/models/faq/mipt/en_mipt_faq_v4/en_mipt_answers.dict]
2019-12-26 13:10:54.138 INFO in ‘deeppavlov.models.sklearn.sklearn_component’[‘sklearn_component’] at line 203: Loading model sklearn.linear_model:LogisticRegression from /Users/michaelwechner/.deeppavlov/models/faq/mipt/en_mipt_faq_v4/logreg.pkl
2019-12-26 13:10:54.138 INFO in ‘deeppavlov.models.sklearn.sklearn_component’[‘sklearn_component’] at line 210: Model sklearn.linear_model.logisticLogisticRegression loaded with parameters
2019-12-26 13:10:54.138 WARNING in ‘deeppavlov.models.sklearn.sklearn_component’[‘sklearn_component’] at line 216: Fitting of loaded model can not be continued. Model can be fitted from scratch.If one needs to continue fitting, please, look at warm_start parameter

I tried to find a way to set the parameter “warm_start”, but unfortunately did not find anything which would have helped.

Any idea what I might be doing wrong?

Thanks

Michael

Hi Michael,

The simplest way would be to remove the /Users/michaelwechner/.deeppavlov/models/faq/mipt/en_mipt_faq_v4/ directory before training.

But if I were you, I would change all the save_path and load_path parameters it the config to suit me better and remove the download block from metadata.
It can look something like this: https://gist.github.com/yoptar/6442bd215deaee24337e5372602f8a79

I also think that it’s better to not store you own configuration files in the package itself, as they can be deleted if you decide to update for example. You can run

python -m deeppavlov train path/to/your/config.json

to run deeppavlov with any config.

Hi Aleksei

Great, thank you very much! It is working now :slight_smile:

I have another question, but will open another thread/topic, because it is not directly related to this problem.

Thanks

Michael